Html Agility Pack para .NET 2.0

.net html-agility-pack nuget visual-studio-2010

Pregunta

Tengo un proyecto de Visual Studio 2010 que se enfoca en .NET v3.5 (es un sitio de Sharepoint). Necesito usar Html Agility Pack en mi proyecto, pero obviamente no puedo usar la versión .NET v4.0.

Descargué el Html Agility Pack de codeplex y agregué una referencia a la DLL en el Net20/ (.NET v2.0) a mi proyecto de Visual Studio. Sin embargo, cuando voy y verifico las propiedades de referencia, dice que la "Versión en tiempo de ejecución" es "v4.0.30319" en lugar de "v2.0.xxxxx", y por lo tanto mi proyecto no se compilará.

"OK ..." dije y probé de forma más oficial, con NuGet usando el Package Manager en Visual Studio . Instalo Html Agility Pack, pero de nuevo no se compila porque la versión de tiempo de ejecución es para .NET v4.0 ...

¿Puedo configurar de alguna manera la versión que quiero instalar en NuGet, o lo hace automáticamente? ¿Me estoy jodiendo por algún error de que los desarrolladores de HAP no proporcionan la DLL correcta para .NET v2.0?

Esto es muy frustrante, ya que literalmente necesito compilar este código que sé que funciona en .NET v4.0 y este proyecto se realizará. Cualquier ayuda es muy apreciada.

Respuesta aceptada

Lo que terminó trabajando para mí fue la versión aquí . Descargué los "binarios", agregué la DLL y la versión en tiempo de ejecución era .NET 2.0 según fuera necesario. Mi programa funciona como lo hizo bajo .NET 4.0.


Respuesta popular

Pruebe este: debería ser .Net 2.0 - http://htmlagilitypack.codeplex.com/releases/view/272



Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué
Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué