设置HtmlAgilityPack以使用Mono for Android

c# html-agility-pack xamarin.android

我之前曾问过类似的问题,但没有人回答。如何设置HtmlAgilityPack与Mono for Android一起使用?我添加了对.dll引用,但在尝试使用HtmlDocument我得到了错误

缺少System.Xml版本2.0.0.0或4.0.0.0。

但是有一个对System.Xml版本2.0.5.0的默认引用。如果我引用4.0.0.0它可以工作,但然后一些Mono for Android的东西不起作用。这里的用户给了我一个特定于Android的版本,但似乎它不包含HtmlWeb ,这意味着它没用。如何设置HtmlAgilityPack与Mono for Android一起使用?


Related

许可下: CC-BY-SA with attribution
不隶属于 Stack Overflow
许可下: CC-BY-SA with attribution
不隶属于 Stack Overflow